A good syllabus serves as a roadmap for the course, but writing a syllabus from scratch can take hours you don't have. SchoolAI turns your course outline into a clear, complete syllabus in minutes — so you can spend your prep time on teaching, not formatting.
To use the Syllabus Tool
Go to Tools > Syllabus > Generate.
Write in your prompts and upload any supporting documentation you may have. Click Generate.
The syllabus will appear in a text editor. Tailor it however you like: highlight text and apply new AI Tools or press the backslash (/) key (on a blank line) to open the options menu.
The document will auto-save as you go. When you’re done, you can share it through a link, export it as a PDF, or export it to a Google Doc or Google Classroom.
Use your AI-generated syllabus as a first draft. Review and customize to make sure it's exactly what your classroom needs.
AI Tools
To edit the text using AI, highlight text in the document and choose "AI Tools" in the toolbar at the top. You can change the tone, translate, simplify, and more.
Options menu
Type the backslash key on a new line to open the options menu. You can generate AI text or images, charts, tables, bullets/numbers, and more.
Frequently Asked Questions
How do I find the syllabus I’ve made?
Syllabi you’ve created can be found and edited by going to Tools > Syllabus > [Number] documents.
How do I share the syllabus document with other teachers?
When the syllabus is open in the text editor, choose Share to copy the link and send it to anybody (most teachers use email). The link leads to a version that can’t be edited by the recipient. You can also use the Export button to share via Google Docs or PDF.
Tip: You’ll need to make sure the document is closed on your end. Otherwise, the link won’t work.
