Skip to main content

Edit a document

Re-prompt or edit documents created from Tools

After you create a document using Tools, you'll be taken to a text editor where you can edit it directly or re-prompt sections using AI — similar to editing in Google Docs, but with AI assistance built in.

You'll find all the tools you need to tailor the material, our AI assistant can help you

  • meet specific student needs and learning goals

  • align materials with your teaching style and curriculum

  • enhance engagement by incorporating relevant examples

  • differentiate instruction to accommodate diverse learning levels

To edit a document you’ve already created:

  1. Find the document you created by going to the Tool you used to create it (click "Tools" in the left-hand menu, then choose your tool). You can also find documents in Tools > Recent Documents.

  2. Use the options at the top to change the style and format of your document (as you would with a Google Doc or in Microsoft Word).

Add text or images

For more options, including images, type the backslash (/) symbol into a new line on the document. This opens up a new menu with several options for making changes, including the ability to add AI-generated images directly into your document.

Choose from your menu options to add an AI-generated image, a table, or for other features like block quotes and task lists.

Re-prompting sections of the document using AI

Sometimes, you may want to adjust only a portion of the generated document by re-prompting. You can ask the AI to shorten, simplify, or change the tone of your text. To use AI to change specific sections of the document:

  1. Highlight the section of your document you’d like to re-prompt.

  2. Select the AI tools button from the toolbar: this will open a menu with options for editing.

  3. Make a selection from the given options to automatically change the text. Otherwise, choose Custom Prompt to edit in a new way.

  4. A new prompt box will be inserted right into the document. The original text is located at the top, and you can enter instructions for your new prompt below.

  5. Type your new prompt into the prompt box and use the dropdown option to change the tone.

  6. Select Generate text, then select Insert when you’re confident with the changes.

Your documents are saved automatically. Share or export the documents using the buttons at the top of the page.

Printing your document

Currently, SchoolAI does not support printing directly from the Editor. To print your document, you’ll need to follow these simple steps:

  1. Export Your Document: Click the Export button located in the upper right-hand corner of the Editor.

  2. Save the File to Your Computer: Choose your preferred file format and save the exported document to your computer.

  3. Print the Document: Open the saved file on your computer and print it using your printer’s settings.

By exporting your document first, you’ll have the flexibility to print from any device connected to a printer.


Frequently Asked Questions

How do I insert an AI-generated image into my document?

To create an AI-generated image, start in a document you’ve created using Tools.

  1. Find the document you want to add the image to by going to the Tool you used to create it. You can also find documents in Tools > Recent Documents

  2. Press the backslash (/) key on your keyboard to open the options menu

  3. Choose an AI image and write the prompt with what you’d like to see. Use the dropdown to further customize the image style

  4. Select Generate image. You can edit text on other parts of the document while you wait for the image to generate

  5. Choose to Discard, Insert, or Regenerate

    Learn more about AI-generated images here.

How do I save the document as a Microsoft Word file?

We currently do not have an option to export to Microsoft Word. Instead, to get a Microsoft Word document:

  1. Export the document to a Google Doc

  2. In Google Docs, go to File > Download > Microsoft Word

How do I add the document to Google Classroom?

Google Classroom must already be linked to your account in order to add the document. After linking your Google Classroom:

  1. Open the document

  2. Choose Export

  3. Choose Google Classroom

Did this answer your question?