Skip to main content

Use the Build Your Own Tool

Create any document you need in seconds

Describe what you need, and the Build Your Own Tool creates it. While SchoolAI's templates cover the paperwork, tests, and quizzes most classrooms need, Build Your Own Tool is there for everything else — built from your own instructions, generated by AI.

To use the Build Your Own Tool

  1. Go to Tools > Build Your Own > Generate.

  2. Write in your prompts and upload any supporting documentation you may have. Click Generate.

  3. The document will appear in a text editor. Tailor it however you like: highlight text and apply new AI Tools or press the backslash (/) key (on a blank line) to open the options menu.

  4. The document will auto-save as you go. When you’re done, you can share it through a link, export it as a PDF, or export it to a Google Doc or Google Classroom.

Use your AI-generated document as a first draft. Review and customize to make sure it's exactly what your classroom needs.

AI Tools

To edit the text using AI, highlight text in the document and choose "AI Tools" in the toolbar at the top. You can change the tone, translate, simplify, and more.

Options menu

Type the backslash key on a new line to open the options menu. You can generate AI text or images, charts, tables, bullets/numbers, and more.


Frequently Asked Questions

How do I find a Build Your Own document I’ve made?

Any Build Your Own Tool documents you’ve created can be found and edited by going to Tools > Build Your Own > [Number] documents.

What are some examples of a Build Your Own Tool?

Teachers use the Build Your Own Tool to create things like:

  • A choice board with three reading-response options for a novel unit

  • Differentiated worksheets with varying levels of difficulty for the same lesson

  • A training module or resource for a PD session or professional learning community

  • A simulated experiment or virtual field trip for a topic you can't teach hands-on

How do I share the Build Your Own document with other teachers?

When the document is open in the text editor, choose Share to copy the link and send it to anybody (most teachers use email). The link leads to a version that can’t be edited by the recipient. You can also use the Export button to share via Google Docs or PDF.

Tip: You’ll need to make sure the document is closed on your end. Otherwise, the link won’t work.

Did this answer your question?